Welcome to PlantUML Q&A, where you can ask questions and receive answers from other members of the community.

You can also submit new features request and vote for them.

Sequence Participant Color Missing

0 votes

I've been working with several sequence diagrams over the past year, and I use background colors to add meaning to the various participants. Today I noticed that most of the participant shapes no longer appear to be using their assigned colors - they just use the default pale yellow.

I update my plantum.jar file once every few months or so, but I can't tell when exactly this started. I'm using version 8053 (which I pulled down today). I dont know which version I had before, nor do I know if the issue existed in that version. I can look back at past PNG files that were generated, and verify that the colors appeared correctly before. I also used the example from the website to try a test file:

@startuml
 
participant Foo0 #Pink
actor Foo1 #Pink
boundary Foo2 #Pink
control Foo3 #Pink
entity Foo4 #Pink
database Foo5 #Pink
Foo1 -> Foo2 : To boundary
Foo1 -> Foo3 : To control
Foo1 -> Foo4 : To entity
Foo1 -> Foo5 : To database
 
@enduml
 
Only the participant and the actor shapes turn pink - the rest stay pale yellow
 
Could there be some kind of version or settings conflict on my machine? Is there some change to syntax that I'm missing? Or could this have been disabled by design?
asked Jan 14 in bug by anonymous
edited Jan 14

1 Answer

0 votes
 
Best answer
Many thanks for the feedback.
It's simply a regression, something we really don't like!

So here is a new beta that fixes this regression https://dl.dropboxusercontent.com/u/13064071/plantuml.jar

Could you test it and confirm that it's working for you now ?

Thanks, and sorry about that!
answered Jan 14 by plantuml (112,180 points)
Works great, thanks for the quick fix!
Support This Project Offer 250 Mo! Follow PlantUML on Twitter
...