Welcome to PlantUML Q&A, where you can ask questions and receive answers from other members of the community.

You can also submit new features request and vote for them.

new SourceStringReader(data).generateImage(outputStream) generates correct graph but with some wrong lines

0 votes

Hi,

when the app is working for a long times (days), new SourceStringReader(data).generateImage(outputStream) generates a correct graph but with some lines starting at top instead of at correct position. Do you know what could be causing this?

Thanks,

Hugo

 

asked Feb 27, 2016 by anonymous

1 Answer

0 votes
This is indeed really weird!
We have no idea about what could cause this.
However, this need to be investigate, and we have several questions:

- Once this happens, does it happen on *every* graph ? Or only to some graphs ?
- Is this only for PNG output ? Or SVG ?
- On average, how many days does it take to have such a behaviour ?

You can contact us by email if you prefer.

Regards,
answered Feb 28, 2016 by plantuml (124,290 points)
Thanks for you answer. Today I'm able to answer your questions.
This was reported for sequence diagrams and class diagrams.
The svg output shows the correct graph only png fails.
I restart the server every day, but this issue happens anyway, so I think it can be reproduced in less than 24 hours but not always.
Very strange.
Could you send us the result of the diagram :
@startuml
version
@enduml
Thanks
Could you upgrade to last version of PlantUML ? The version you are using is very old.

It is also very possible that the issue is related to OpenJDK. If possible, could you try with another JVM ?

Thanks,
Thanks, I will try it!
Thanks for your help.
I have upgraded jdk to Oracle jdk-8u121, and plantuml.jar to 8056
but the problem persist.
Any other idea?
This one will probably be very difficult to solve.
Could you contact us by email ? (plantuml@gmail.com)
Thanks!
Support This Project Offer 250 Mo! Follow PlantUML on Twitter
...