Welcome to PlantUML Q&A, where you can ask questions and receive answers from other members of the community.

You can also submit new features request and vote for them.

Has version 8005 broken the Eclipse plugin?

+1 vote
My diagrams, which were working with the Eclipse plugin 8004, do not work at all with 8005.

Eclipse displays the following error message repeatedly:

    Error during image generation.
    net/sourceforge/plantuml/FileSystem

I can post an example if required, but this happens with all my diagrams so I suspect something is fundamentally broken.

Please advise.

Thanks,
--Alan Gillespie
asked Sep 15, 2014 in bug by anonymous

2 Answers

0 votes
Yes, you are right : we've broken the Eclipse plugin with 8005.

We will publish 8006 tomorrow to fix this.

Sorry about that...
answered Sep 15, 2014 by plantuml (125,210 points)
Can you possibly add the 8004 back to the update site so we can roll back?
Thanks. Is it possible to reinstall the 8004 plugin, and, if so, is there a URL to which I can point Eclipse to get it?
We need some time to reinstall 8004.
You can use this alternate update site http://basar.idi.ntnu.no/svn/tdt4100/anonymous/trunk/updatesite/
(But this is probably outdated)

In the future, we will have to versions available at the same time to avoid this kind of issue.
Sorry again about it...
0 votes

We've just commited V8007 that solves this issue.

Sorry for the inconvenience!

answered Sep 15, 2014 by plantuml (125,210 points)
Everything is working again :)
First class support. Thank you :)
Support This Project Offer 250 Mo! Follow PlantUML on Twitter
...